const regex = /AM19\/0[6-8][0-9][0-24-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('AM19\\\/0[6-8][0-9][0-24-9]', 'gm')
const str = `AM19/0601
AM19/0805
AM19/0803
AM19/0601,AM19/0602,AM19/0803`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}