$re = '/\b[A-Z]+\b/m';
$str = 'The lazy LAD was sorry for the debacle
She wept as her FLAXEN hair tumbled down the parapet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);