import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bBEGIN\\b([\\w\\n]*?)\\bEND\\b\\n)";
final String string = "a\n"
+ "b\n"
+ "BEGIN\n"
+ "c\n"
+ "d\n"
+ "e\n"
+ "END\n"
+ "f\n"
+ "g\n"
+ "h\n"
+ "i\n"
+ "j\n"
+ "BEGIN\n"
+ "k\n"
+ "l\n"
+ "m\n"
+ "n\n"
+ "o\n"
+ "p\n"
+ "q\n"
+ "END\n"
+ "r\n"
+ "s\n"
+ "t\n"
+ "u\n"
+ "v\n"
+ "BEGIN\n"
+ "w\n"
+ "x\n"
+ "y\n"
+ "END\n"
+ "z";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}