package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(.*)-`)
var str = `<SM1-SRVNET-P:Sys`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}