using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=a(?:bc|cb)|b(?:ca|ac)|c(?:ab|ba))\w+";
string input = @"abc acb bac bca cab cba ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}