package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{2}\/\d{2}\/\d{4}\s\d{2}:\d{2}`)
var str = `yyyy/MM/dd HH:mm
2017/08/26 12:02
dd/MM/yyyy HH:mm
26/08/2017 12:02`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}