import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}\\/\\d{2}\\/\\d{4}\\s\\d{2}:\\d{2}";
final String string = "yyyy/MM/dd HH:mm\n"
+ "2017/08/26 12:02\n\n"
+ "dd/MM/yyyy HH:mm\n\n"
+ "26/08/2017 12:02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}