#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(ТП 2-2/250-Ф1-))\d+(\/\d+)?"
Local $sString = "ТП 2-2/250-Ф1-1-2-НД(1)-Б" & @CRLF & _
"ТП 2-2/250-Ф1-3/32-3-НД(1)-Б" & @CRLF & _
"ТП 2-2/250-Ф1-26-Д" & @CRLF & _
"ТП 2-2/250-Ф1-72/23-Д"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")