using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(ТП 2-2/250-Ф1-))\d+(\/\d+)?";
string input = @"ТП 2-2/250-Ф1-1-2-НД(1)-Б
ТП 2-2/250-Ф1-3/32-3-НД(1)-Б
ТП 2-2/250-Ф1-26-Д
ТП 2-2/250-Ф1-72/23-Д";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}