#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{2}(\.|\s)?[0-9]{3}(\.|\s)?[0-9]{2}\n"
Local $sString = "80020509" & @CRLF & _
"80.020-050" & @CRLF & _
"80-250.404" & @CRLF & _
"80.405.405" & @CRLF & _
"80405.405"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")