using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{2}(\.|\s)?[0-9]{3}(\.|\s)?[0-9]{2}\n";
string input = @"80020509
80.020-050
80-250.404
80.405.405
80405.405";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}