using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Hello I am (?:really )?him\.";
string input = @"Hello I am really him.
Hello I am him.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}