import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ApWord>((\\w+)(')(\\w+)))|(?<HyWord>((\\w+)(-)(\\w+)))|(?<Rest>\\w+)";
final String string = "something else +good -bad 'other stuff' ++'good stuff' -\"bad stuff\" ---\"dall'orto\" a v I_m a and bdc\n"
+ "let's see if other-stuff works let1234 a123d k n _d .,;'\\]=!@#$%^&**(())_++}{[]\\\":';/.,. But what about Mr. Jones";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}