$re = '/(?<ApWord>((\w+)(\')(\w+)))|(?<HyWord>((\w+)(-)(\w+)))|(?<Rest>\w+)/m';
$str = 'something else +good -bad \'other stuff\' ++\'good stuff\' -"bad stuff" ---"dall\'orto" a v I_m a and bdc
let\'s see if other-stuff works let1234 a123d k n _d .,;\'\\]=!@#$%^&**(())_++}{[]\\":\';/.,. But what about Mr. Jones';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);