// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(подрост:\s+)(?<composition>[0-9А-Я]+)?\s?(?<age>\(\d+\))?\s?(?<height>\d+,\d\sм)?\s?,?\s?(\d+,\d\s+тыс.шт\/га),?([А-Яа-я]+)?").unwrap();
let string = "подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 1,5 тыс.шт/га
подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}