import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\S.+\\nCoverage\\sLevel)|^(?=\\S.+\\nNon-Covered\\s)";
final String string = "Out of Pocket (Stop Loss)\n"
+ "Coverage Level: Individual\n"
+ "Service Type: Health Benefit Plan Coverage\n"
+ "Insurance Type Code: HM Health Maintenance Organization (HMO)\n"
+ "Time Period Qualifier: Calendar Year\n"
+ "Amount: $8,500.00\n"
+ "In Plan Network Indicator: Unknown\n"
+ "Deductible\n"
+ "Coverage Level: Individual\n"
+ "Service Type: Vision (Optometry)\n"
+ "https://luna.ema.md/ema/patient/InsuranceOverviewForm.action?pic1.0u85-w2bBh0R86_K9v71KolpMN1sZmZ0Lxolu1TW4qD3al-JJFDVNX81... 13/172/21/22, 10:26 AM Luna Dermatology: Patient Insurance\n"
+ "Insurance Type Code: HM Health Maintenance Organization (HMO)\n"
+ "Plan Coverage Description: Fidelis Care Silver\n"
+ "Amount: $0.00\n"
+ "Authorization/Certification Req'd: No\n"
+ "In Plan Network Indicator: no\n"
+ "Co-Payment\n"
+ "Coverage Level: Individual\n"
+ "Service Type: Vision (Optometry)\n"
+ "Insurance Type Code: HM Health Maintenance Organization (HMO)\n"
+ "Plan Coverage Description: Fidelis Care Silver\n"
+ "Amount: $0.00\n"
+ "Authorization/Certification Req'd: No\n"
+ "In Plan Network Indicator: Yes\n"
+ "Co-Insurance\n"
+ "Coverage Level: Individual\n"
+ "Service Type: Vision (Optometry)\n"
+ "Insurance Type Code: HM Health Maintenance Organization (HMO)\n"
+ "Plan Coverage Description: Fidelis Care Silver\n"
+ "Authorization/Certification Req'd: No\n"
+ "In Plan Network Indicator: Unknown\n\n"
+ "Out of Pocket (Stop Loss)\n"
+ "Coverage Level: Family\n"
+ "Service Type: Health Benefit Plan Coverage\n"
+ "Insurance Type Code: HM Health Maintenance Organization (HMO)\n"
+ "Time Period Qualifier: Remaining\n"
+ "Amount: $16,190.82\n"
+ "In Plan Network Indicator: Unknown\n"
+ "Non-Covered\n"
+ "Coverage Level: Individual\n"
+ "Service Type: Medical Care\n"
+ "Insurance Type Code: HM Health Maintenance Organization (HMO)\n"
+ "Plan Coverage Description: Fidelis Care Silver\n"
+ "In Plan Network Indicator: No\n"
+ "Message: Medical Care\n"
+ "Non-Covered\n"
+ "Coverage Level: Individual\n"
+ "Service Type: Durable Medical Equipment Purchase\n"
+ "Insurance Type Code: HM Health Maintenance Organization (HMO)\n"
+ "Plan Coverage Description: Fidelis Care Silver\n"
+ "In Plan Network Indicator: No\n"
+ "Message: DME Purchase";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}