import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/)[a-z0-9-]+?$";
final String string = "/magasins/vos-magasins/le-bhv-marais\n"
+ "/magasins/vos-magasins/le-bhv-marais-homme\n"
+ "/magasins/vos-magasins/bhv-marais-parly2\n"
+ "/magasins/le-bhv-marais-la-niche\n"
+ "/magasins/vos-magasins/mobicity-au-bhv-marais\n"
+ "/magasins/vos-magasins/gucci-au-bhv-marais";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}