use strict;
my $str = '/magasins/vos-magasins/le-bhv-marais
/magasins/vos-magasins/le-bhv-marais-homme
/magasins/vos-magasins/bhv-marais-parly2
/magasins/le-bhv-marais-la-niche
/magasins/vos-magasins/mobicity-au-bhv-marais
/magasins/vos-magasins/gucci-au-bhv-marais';
my $regex = qr/(?<=\/)[a-z0-9-]+?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}