const regex = /\(\s*;(?:[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*(?:\s*[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*)*)?\s*(?:;(?:[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*(?:\s*[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*)*)?(?:\s*;(?:[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*(?:\s*[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*)*)?)*)?\s*(?:\((?:;(?:[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*(?:\s*[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*)*)?(?:\s*;(?:[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*(?:\s*[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*)*)?)*)?\)(?:\((?:;(?:[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*(?:\s*[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*)*)?(?:\s*;(?:[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*(?:\s*[A-Z](?:\s*[A-Z])*\s*\[(?:\\\]|[^\]])*\](?:\s*\[(?:\\\]|[^\]])*\])*)*)?)*)?\))*)?\s*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?\\s*(?:;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?(?:\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?)*)?\\s*(?:\\((?:;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?(?:\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?)*)?\\)(?:\\((?:;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?(?:\\s*;(?:[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*(?:\\s*[A-Z](?:\\s*[A-Z])*\\s*\\[(?:\\\\\\]|[^\\]])*\\](?:\\s*\\[(?:\\\\\\]|[^\\]])*\\])*)*)?)*)?\\))*)?\\s*\\)', 'g')
const str = `(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd];W[dd];B[pq];W[dp])
(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd];W[dd](;B[pq];W[dp])(;B[dp];W[pp]))
(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd];W[dd](;B[pq];W[dp])(;B[dp];W[pp];PL[B]AE[jk]AB[jj]AW[ji];B[jq]))
(;GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25];B[pd]C[Comment on move.];W[dd](;B[pq];W[dp])(;B[dp];W[pp];PL[B]AE[jk]AB[jj]AW[ji]C[Comment on editing.];B[jq]))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}