import Foundation
let pattern = #"^(api|f)(\d{0,3})?\.backblazeb2\.com(\/.*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
api.backblazeb2.com
api000.backblazeb2.com
api001.backblazeb2.com
api002.backblazeb2.com
api003.backblazeb2.com
api004.backblazeb2.com
api005.backblazeb2.com
f000.backblazeb2.com
f001.backblazeb2.com
f002.backblazeb2.com
f003.backblazeb2.com
f004.backblazeb2.com
f005.backblazeb2.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)