use strict;
my $str = 'getThis, getThat, getSomethingElse';
my $regex = qr/get(\w+)/mp;
my $subst = '\\l$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";