import Foundation
let pattern = #"get(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"getThis, getThat, getSomethingElse"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\l$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)