re = /\[IMG\]http:\/\/i64\.tinypic\.com\/(.*?)\[\/IMG\]/i
str = '[IMG]http://i64.tinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.nottinypic.com/2zgg086.jpg[/IMG]
[IMG]http://i64.tinypic.com/2zgg0cdsc86.jpg[/IMG]
[img]http://i64.tinypic.com/2zgg086.jpg[/IMG]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end