use strict;
my $str = '2023-02-28T00:00:00.000Z
2023-02-29T00:00:00.000Z
2024-02-29T00:00:00.000Z
2023-06-30T00:00:00.000Z
2023-06-31T00:00:00.000Z
2023-07-31T00:00:00.000Z
2023-07-31T00:00:00.000-05:30
2023-07-31T00:59:59.000Z
2023-07-31T00:60:59.000Z
2023-07-31T00:59:60.000Z';
my $regex = qr/^((\d\d[2468][048]|\d\d[13579][26]|\d\d0[48]|[02468][048]00|[13579][26]00)-02-29|\d{4}-((0[13578]|1[02])-(0[1-9]|[12]\d|3[01])|(0[469]|11)-(0[1-9]|[12]\d|30)|(02)-(0[1-9]|1\d|2[0-8])))T([01]\d|2[0-3]):[0-5]\d:[0-5]\d\.\d{3}([+-]([01]\d|2[0-3]):[0-5]\d|Z)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}