package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)s(\d)`)
var str = `NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]`
var substitution = "S\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}