use strict;
my $str = 'NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]';
my $regex = qr/s(\d)/mp;
my $subst = 'S\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";