import Foundation
let pattern = #"(?i).*?\bfloor area:?\s*(\d+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift
Newbuild flat. Floor Area: 30 sq.m","6 bed house with floor area 50 sqm, lot area 25 sqm
6 bed house with floor area 50 sqm, lot area 25 sqm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)