import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfloor area:?\\s*(\\d+)";
final String string = "A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift\n"
+ "Newbuild flat. Floor Area: 30 sq.m\",\"6 bed house with floor area 50 sqm, lot area 25 sqm\n"
+ "6 bed house with floor area 50 sqm, lot area 25 sqm";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}