// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^View_Export_(US_(?:GoM|Horizontals|Onshore))(?:_(Ultimate))?_(\w+)").unwrap();
let string = "View_Export_US_Horizontals_Ultimate_DirectionalSurveys";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}