re = /((\d*(?:,?\.?)\d*(?:,?\.?))\s?\/\s?(\d*(?:,?\.?)\d*(?:,?\.?)))(?!\s?x)/m
str = 'dummy word 222/2334; Ø14 x Ø6,33/523,23 x 2311 mm
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end