const regex = /^[_.][0-9]+[a-zA-Z]*_{0,1}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[_.][0-9]+[a-zA-Z]*_{0,1}$', '')
const str = `_0898989811abced_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}