$re = '/(Past 30 Days\s*)([^-]*)([^]]+)/';
$str = 'Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]
Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]
Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]
Radio Stations-Listened to Past Week-Quebec City [FM-CFEL-102.1 (blvd 102.1)]';
$subst = "$1$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;