import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\.+?(?= \\|)";
final String string = "| Area | vserver | file-id |connection-id | session-id | open-mode | path |\n"
+ "| manphsan01 | manphs101 | 9980 | 4278018043 | 5065142205921760710 | rw | Share01\\Mandaue\\Data01 |\n"
+ "| manphsan01 | manphs101 | 1790 | 4278020659 | 5065142205921763223 | rwd | FinanceDept\\ARCHIVING |\n"
+ "| manphsan01 | manphs101 | 1824 | 4278020659 | 5065142205921763223 | rwd | Share01\\Cebu\\Year2022 |\n"
+ "| manphsan01 | manphs101 | 1976 | 4278020659 | 5065142205921763223 | rwd | SGSDept\\General\\Document | more |\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}