$re = '~^(https?:)?//([^/]*\.)?example\.com/?~m';
$str = 'With protocol:
http://example.com
https://example.com/folder/file.txt
https://www.example.com/toto
https://sub-domain.example.com
https://sub-sub.sub.example.com
https://www.google.com/?q=example.com
Without protocol:
//example.com/no-i-do-not-want-it-either
//valid.com/blablabla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);