import Foundation
let pattern = #"^(https?:)?//([^/]*\.)?example\.com/?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
With protocol:
http://example.com
https://example.com/folder/file.txt
https://www.example.com/toto
https://sub-domain.example.com
https://sub-sub.sub.example.com
https://www.google.com/?q=example.com
Without protocol:
//example.com/no-i-do-not-want-it-either
//valid.com/blablabla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)