$re = '/([A-Z]{2,5}:\w+(?: +\w+)*)(?=(?: +[A-Z]+:|$))/m';
$str = 'YellowSky AA:Hello AB:1234 AC:1F 322 AD:hj21jkhjk23
Billy Bob Thorton AA:213231 AB:aaaa AC:ddddd 322 AD:hj2ffs dsfdsfd1jkhjk23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);