import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<Person[\\d\\s]+|>)";
final String string = "<Person 1234567 Tom Brady>\n"
+ "<Person 456789012 Mary Ann Thomas>\n"
+ "<Person 92145 John Smith>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}