$re = '/href\=\\\\\"(?<url>[^ ]*)/m';
$str = 'search_name=x, search_now=3.000, info_min_time=1692741600.000, info_max_time=1692828000.000, info_search_time=1692847620.636, app=Digital,
text="<a href=\\"https://support.vodafone.co.uk/1627646512 \\" target=\\"_blank\\"> ...etc ", info_log=l';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);