// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href\=\\\"(?<url>[^ ]*)"#).unwrap();
let string = "search_name=x, search_now=3.000, info_min_time=1692741600.000, info_max_time=1692828000.000, info_search_time=1692847620.636, app=Digital,
text=\"<a href=\\\"https://support.vodafone.co.uk/1627646512 \\\" target=\\\"_blank\\\"> ...etc \", info_log=l";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}