re = /^\d{6}(?:,\s\d{6})*$/m
str = '123456
123456, 456789, 987654
,
1
123456
123456,
,123456
123456,123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end