import Foundation
let pattern = #"^[A-Z][a-z\'\s]+:[A-Z\s]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Eminem:VENOM
Linkin park:NUMB
Drake:NONSTOP
Adele:HELLO
Michael Jackson:ANOTHER PART OF ME
Adele:ONE AND ONLY
Guns n'roses:NOVEMBER RAIN
Christina Aguilera: HuRt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)