#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])$"
Local $sString = "102.242.234.121" & @CRLF & _
"243.171.221.0" & @CRLF & _
"243.171.221.0.0" & @CRLF & _
"170.132.134.555" & @CRLF & _
"000.000.000.000" & @CRLF & _
"195.103.67.52" & @CRLF & _
"110.128.244.14" & @CRLF & _
"243.221.0" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")