package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])$`)
var str = `102.242.234.121
243.171.221.0
243.171.221.0.0
170.132.134.555
000.000.000.000
195.103.67.52
110.128.244.14
243.221.0
// You can show origina post on albertcolom.com/blog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}