// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<p><span style=\"font\-size:16px\">(.*)?<\/span><\/p>"#).unwrap();
let string = "<div class=\"text\"> <p><span style=\"font-size:16px\">As notas do Exame Nacional do Ensino Médio (Enem) 2017 foram divulgadas nesta quinta-feira (18). O resultado deve ser consultado individualmente: para isso, os candidatos devem acessar a Página do Participante (https://enem.inep.gov.br/participante/) e incluir CPF e a senha cadastrada. </span></p> <p><span style=\"font-size:16px\">O resultado dos treineiros só será divulgado em 19 de março. Na mesma data, o Ministério da Educação também vai disponibilizar os chamados \"espelhos da redação\", que são a cópia digitalizada dos textos e as justificativas para as notas. </span></p> <p><span style=\"font-size:16px\">Nesta quinta, o Ministério da Educação (MEC) divulgou o balanço sobre o desempenho dos candidatos na edição de 2017 do exame. Apenas 53 alunos tiraram nota mil na redação, porém a nota média subiu de 541,9 para 558. Neste ano, os candidatos escreveram sobre o tema \"Desafios para a formação educacional de surdos no Brasil\".</span></p> <p><span style=\"font-size:16px\">Com a nota do Enem 2017, os estudantes podem concorrer a uma vaga em uma universidade pública que tenha aderido ao Sistema de Seleção Unificada (Sisu) 2018. As vagas já podem ser consultadas. Serão 130 instituições no Brasil - 30 estaduais e 100 federais -, que ofertarão 239.601 vagas na graduação.</span></p> <p><span style=\"font-size:16px\">Para participar, é necessário ter tirado nota acima de zero na redação do Enem 2017. Como nos anos anteriores, cada candidato poderá se inscrever em até duas vagas, especificando a ordem de preferência e o turno no qual pretende estudar. </span></p> <p><span style=\"font-size:16px\">A pesquisa está registrada sob o número TSE: PA-0472/2012.</span></p> </div> .</span></p> <p><span style=\"font-size:16px\">O levantamento, encomendado pela Rede Amazônica, retransmissora da Rede Globo, divulgado nesta sexta-feira, 5, foi feito entre os dias 3 a 5 de outubro , com 812 entrevistados. A margem de erro é 3 pontos percentuais, e o nível de confiança é de 95%.</span></p>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}