#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,"
Local $sString = " a."Id"," & @CRLF & _
" a."Description"," & @CRLF & _
" UJsonObject(" & @CRLF & _
" fepv."Id"," & @CRLF & _
" fepv."SystemName"," & @CRLF & _
" string_agg(translations."Translations", ',') as "Translations"" & @CRLF & _
" ) as "Translations"," & @CRLF & _
" b."DataSource"," & @CRLF & _
" a."Name"," & @CRLF & _
" a."Value""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")