re = /(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,/m
str = ' a."Id",
a."Description",
UJsonObject(
fepv."Id",
fepv."SystemName",
string_agg(translations."Translations", \',\') as "Translations"
) as "Translations",
b."DataSource",
a."Name",
a."Value"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end