import Foundation
let pattern = #"^(?<id>[^=]+)=(?:<Picture id="(?<picture>[^"]*)"\/?>)?(?<stuff><[^>]*>)?(?<description>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id="ICN_PRM_007"/>Wind attack power +{Perc}%
STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id="Yellow">reward</Color>, so give it your all!
STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)