const regex = new RegExp('(?<=v\\\\u003d)([a-zA-Z0-9-]*)', 'gm')
const str = `https://www.youtube.com/watch?v\\u003d-EMFXVcMWxo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}