re = /(?<=v\\u003d)([a-zA-Z0-9-]*)/m
str = 'https://www.youtube.com/watch?v\\u003d-EMFXVcMWxo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end