re = /^.*(?=\/test\s)/m
str = '/docs/reports/test reports/document1.docx'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result